Container skips at switch to auto mode


For our news we use a container with the news-file.
If a deejay is in assist mode, and switches to auto mode during this news, the play-out of this file is ended and starts the next track.

Has anyone this problem too?

I tried to reproduce this, but here it’s still running after switching between Assist and Auto.

But it seems there are anyway some more problems with the News-Container. For example I can’t use it for automation.

Is the track after the newscontainer a soft/hard fixed timed item?
This could be a cause

Hey, I have found out when things are going wrong!

Player A: is playing the outtro of a song
Player B is playing the jingle ( or started news)

At pressing Auto, both players stop and the next track in the playlist is started.
In my opionion the last started track should continu playing in auto mode ( and maybe the first track ( Player A in the case above) can be stopped.

I seems this is a bug in Maitlist (6.3).
I understand that 2 playing players can confuse the auto what to do, but it is very annoying if a track is skipped by pressing the auto button.

So maybe @Torben can fix this unwanted feature :wink:

I have a few questions to check if it is really a bug.
Are you using the standard auto button? or have you created your own auto button?

If you have created the button yourself, what is the command you give?

  • Enable Automation
  • Start Automation Playback

The last Command is not only activating the automation, it also have a start function. Perhaps this can be an issue when several items are playing at that same moment. The first command only activates the automation.

Sorry, unable to reproduce this here:

  • ASSIST mode
  • Start song (Player A)
  • Start jingle (Player B)
  • While both are playing, turn on AUTO
  • Nothing is skipped in that moment
  • Jingle will play until EOF, and song will continue to play
  • Thereafter automation continues with next item

What am I doing wrong?

Maybe you are doing it right.

1 Like

Sorry for the late reply.

We use a button, it triggers: Automation 1 on / automation 1 off

Should work.

Maybe its because we have chosen to use one player in automation mode. Ill try to change that and see it it will make a difference.

Hi, do you have any clue on that problem ? I have the same problem but without containers !

In assist mode, when I put AUTO ON while the last track is playing at the end of the show, the track is skipped to the next item in playlist, but not every time… very strange.

I use both players in automation, AUTO mode is switched by the AUTOMATION 1 ON/OFF cmd.


There is an option to “automatically jump to fix-timed elements in automation mode” (translated from the german version) in Config → Playlists → Playlist 1 → Options .

Maybe that causes mAirlist to jump to the next item immediately after going into auto mode esp. when there’s a (hard or soft) fix-timed TOTH after the show?

This happened today, a track was remaining in playlist at the end of the show (after the last actually played), when I switched to AUTO ON, it skiped the current to the last.
And yes, there is a soft fixed time TOH jingle just after (13pm).
Is this a mechanism to catch up time before the soft fixed time item ?

@Stefan_Hillen thanks, I unticked the option.
I’d like to prevent that it skips to next element when I switch AUTO ON, but I’d like to keep the behaviour that it skips automaticaly to the soft fixed time when it’s possible, at the end of a track. Will it continue to work like that ?

1 Like

Maybe @UliNobbe can tell you more about…

I use the way to have the LAST SONG backtimed to the TOTH / End of the hour (with a soft fix-time) and overplan the say 5 minutes before it with 2-3 songs. This way the last song will always be the last song in the list and the Playlist will have some buffer if there’re elements that were skipped by me or were missing (like planned interviews etc)…

But the end of the PL will always be “LAST planned Song” → “TOTH” so there’s no need to skip automatically songs because after the last song it will always play the TOTH.


…would be obsolet then.

Maybe this will work for you too?

I tried “automatically jump to fixed time elements in automation mode” OFF, and yesterday when switched to auto mode ON while a track playing 2 or 3 minutes before 13pm, it skipped to the next one (soft-fixed 13pm Start of the hour), whereas the track wasn’t ended.

Overmore, I have some specials blank playlists for some shows that don’t use mAL to play music. I use hard fixed time items to resume the playback. With “auto jump to fixed time” OFF, at the end of these shows the playout doesn’t resume…

So I prefere keep “auto jump” to ON.

However, it seems to fix the problem described here : Append from DB playlist overlap the newly appended playlist doesn’t overlap anymore with remaining items from previous playlist.

To use backtimed items you have to put ON the “auto jump”, i’m right ?
And how de you backtime the last item, I use mainly “fill with music block” or it can also be a pre-recorded news/interview…