Error loading cart player 0: unsupported sample format (BASS error 6)

#1

Hey,

So I’ve just bought a MOTU Ultralite MK4. It’s set to 24 bit, 48000khz. It has no 16 bit.

Playing audio from my playlist works correctly. But as soon as I add any audio file to my Cartwall, I get this error:

Error loading cart player 0: unsupported sample format (BASS error 6)

So my cartwall doesn’t work. I’ve searched around but I have no idea on how to solve this. I have also tried to disable floating point, but no matter what I do, it just doesn’t work.

#2

This is with DirectSound, I suppose? Have you tried with WASAPI instead?

#3

I read somewhere that you said that a person should always prefer WASAPI, am I correct? So I have tried that, but yes, same issue…

The cartwall only works when I remove the device from the USB port and use a different device. Otherwise, this error happens.

#4

Have you set specific devices for the individual players? Or just the general cartwall playback device?

#5

I tried it for the cartwall playback device. I also tried to select my onboard soundcard, there, and for all devices (not all the individual players, but I did try it for player 1). But I just get a bunch of errors.

By the way, I have tried this also by closing mAirList, then by going to the Configuration, and then opening mAirList again.

I am using the latest snapshot.

#6

@Torben here is a screenshot…
And, for testing purposes I also disabled “Load entire file into RAM” by setting it to 0KB. But that didn’t work either.

#7

Here a similar BASS-Error is conquered by

Maybe you can have a shot at this.

Hoping regards

TSD

#8

Hey Tondose thanks. Yeah… I read it, and I tried it… no success there though :confused:

#9

:worried:




#10

Now I set everything, in Windows AND in mAirList, to 44100. Still the problem: the Cartwall doesn’t work, the playlist does work. I have an empty cartwall. As soon as I drag any file to the Cartwall I get ERROR.

#11

Is there really no way to set that **** thing to 16 bit? You might want to send it back then.

Barbecueing regards

TSD

#12

@Tondose LOL no I need this one… but… @Torben I think I found it!

The device has two output devices … Speaker and Out 1-24

In the configuration… when I go to Audio Settings -> DirectSound, and I set the Out 1-24 mode to Software Mixing, and leave Speaker set to Direct Access (hardware mixing), and set the output devices to Directsound: Speaker (MOTU Device), it works.

I’m not sure if this is a feature or a bug?

#13

Hm. No idea. Buggy drivers perhaps? Looks like these two logical devices have an impact on each other in some way.

#14

Yeah… could be. Anyway. We got it working. :slight_smile: Thank you for helping me.