Stream causing errors

Hi guys,

Just had a bit of an issue yesterday, we’re using 2.2 throughout our station and yesterday we did our first ever live OB. To achieve this, we setup an Icecast server at base and streamed back to it from Edcast (formerly Oddcast) at our OB location, mAirList would then (in theory!) pick up the stream from the Icecast box at 13:00 and play it until 15:00. When we tested it (on a number of our 2.2 machines), mAirList would start giving us an error stack thingy after 2 minutes of perfect streaming and then quit completely, this was using both OGG (the format we eventually used) and MP3.

In the end we resorted to using Winamp which worked flawlessly for the whole 2 hours.

Can anyone think of a reason why mAirList would take such a dislike to our stream?! I’d like to get it sorted so that we can use it in the future instead of Winamp.

Many thanks,

P.S. Can get the call stack thing if needed.

The call stack would indeed be helpful.

Here’s the stack!


Call Stack 26-9.txt (34.1 KB)

Wow, this is a long one…

In case you’re able to reproduce the problem, can you please download from and put it into your mAirList folder? It will make the report even more verbose (and more helpful to more).

Yep, I shall do that tomorrow. It seems to make a new stack every second until it quits.

Great, thanks for that.

Oh, and perhaps you might want to give me the URL to that stream that fails (a PM would just be fine if you prefer). It might help me track this error down.

Apologies for the stream not being active today! Had a rather busy morning and forgot about it. Will try again on Monday!

ditto :wink:

I did a test today, playing the Deutschlandradio stream (Ogg) while I was at the movies (everybody go and watch Wall-E!). Played without any problems for 3+ hours.

So there must be something special about your stream, obviously.

Yeah I figured that! It is streaming out right this minute, but I think our router is having some forwarding problems meaning I can’t access it from home.

Do you have any example Icecast/Edcast settings I can compare?

This is the Deutschlandfunk stream I used for testing:

Thanks, I’ll give it a try later this week.

Strangely, I’ve had no luck. Ended up with the same error with numerous stations. What on earth have I done to the config to make it do this??!

Any idea?


That’s odd.

May I please remind you of what I wrote the other day?

Yes of course! Sorry.

Never mind. It’s just that chances will be better that I can resolve that then.

By the way, v2.2.1 has just been released. The corresponding map file can be downloaded from here:

Hi Torben,
Sorry for the late reply, had a lot of things going on!

Still using 2.2.0, haven’t had a chance to upgrade yet.

Heres the call stack using the Map file.


Call Stack 27-10-08.txt (102 KB)

Hi again,

Just upgraded to 2.2.0 on one of our machines, this time, it will say the stream (I’ve tried a few) is playing but I can’t hear any audio, yet it will play other playlist items fine.

Any ideas?!


Hi there,

Still no change with mAirList breaking when I play a stream. I have found that when I set a duration for the stream there are no problems.

I have attached the latest MAP file for you to look at, I can see lots of references to drawing a progress bar, would this be a problem?!


Call Stack 02-12-2008.txt (97.8 KB)

Looking at the call stack, the issue might in fact be related to the drawing of the progress bar. The hint that it happens only with “infinite” stream items was very helpful. It seems that the does not handle those streams correctly. Although I still haven’t been able to reproduce the problem, so it’s just a guess based on the reports you provided.

I have now modified the progress bar so that it is not drawn for those items, just a rectangle in the “idle” color (usually gray). Can you please try the snapshot I just uploaded (v2.2.1 b542). You just need to download and replace the mAirList.exe file, but in case it still doesn’t work, there’s also an update file in the download folder to generate a call stack.