Sound interrupting

#1

Hi,
i am experiencing interrupting of the sound on my machine when I login from remote computer using Real VNC, or waking the screen up from “black screen”. Interruptions are very short, but annoying and it feels that they shouldn’t occur, because I can run other programs without interrupting the sound experience.
I use 4 instances and dynamic processing, while 1 instance is using encoding from mixer output (Airlite USB).

Processor utilization is at 20-30% during normal runtime.

Has anyone have any idea if I can fix this?

#2

Top 3 tips:

  1. Disable “Audio Enhancements” in Windows Control Panel (if your card/driver has them): https://www.thewindowsclub.com/disable-audio-enhancements-windows-10

  2. Enable “async file reading” in mAirList config -> Audio Settings -> General

  3. Check and possibly increase buffer sizes

And don’t use ASIO unless you have a very good reason. ASIO uses very low buffer sizes and is prone to dropouts. Use WASAPI whenever you can.

#3

I have disabled all Audio Enhancements following the guide. Then, I enabled async file reading and increased buffer size from 50 to 500 ms, but nothing helped.
As I can see/hear, this occurs only when waking the computer when monitor was is sleep mode, and I don’t see why that should interrupt the sound when there is 70-80% overhead for processor to work with. I log in from remote location frequently and it is very annoying to interrupt the sound in this way, and I would not like to have screen on nonstop.

p.s. I am using WASAPI

#4

How about switching the monitor totally OFF – for testing purposes at first. If logging in is nondangerous by then, you’ve caught the mischief. (But in this case I’m afraid we have to blame someone other than mAirList.)

Continuous regards

TSD

#5

Of course, I will test that and come back here… Thanks for helping out

#6

I have tested to run monitor nonstop, and the thing I am noticing is that sound interruption appears at the moment when I turn monitor on/off…
I have also discovered that interruptions doesn’t appear on streams that are not using mixer console. So I am continuing the investigations.
FYI, I am using Airlite mixer console that is connected via USB to the computer. Computer has external monitor attached via HDMI. I am also using software sound processor: Breakaway One for processing the sound on the instance that is interrupting