REST Fernsteuerung TLS 1.2

mAirlList 6.0

Wir nutzen aktuell noch die REST Fernsteuerung mit HTTP. Nun müssen wir HTTPS umstellen.
Offenbar unterstützt mAirList noch kein TLS 1.2 für die REST Schnittstelle

DANKE Michel

Diese Website kann keine sichere Verbindung bereitstellen

127.0.0.1 verwendet ein nicht unterstütztes Protokoll.

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

Details ausblenden

Nicht unterstütztes Protokoll

Client und Server unterstützen keine gemeinsame SSL-Protokollversion oder Verschlüsselungssammlung.

Auszug aus dem mAirList-Wiki bezüglich REST-Fernsteuerung:

General Settings

Specify the TCP Port that the HTTP server should listen on. The default port is 9300.

SSL is currently not supported.

@Torben, V6.3?

Sichere Grüße

TSD

Also bei mir funktioniert das problemlos.


EDIT: und hier, wie man es einstellt

Laut Torben, seit Version 6.0 verfügbar: REST per https

1 Like

Und nun auch im Wiki veröffentlicht.
 

Ergänzte Grüße

TSD

1 Like

Danke dafür!

Grundsätzlich kann man das auch mit einem Reverse-Proxy lösen (z.B. nginx), was ich sogar empfehlen würde, wenn die API sogar über das Internet erreichbar sein soll. Im internen Netz wiederum kann man darüber streiten, ob man SSL überhaupt benötigt.

Die unterstützten SSL-Versionen sind (seit Version 6.0.3) diese hier (Auszug aus dem Changelog):

[*] HTTPS connections now support SSLv3, TLS v1.0, TLS v1.1, TLS v1.2

Die Meldung kam von Firefox, @lifechannel? Vielleicht magst du mal einige Tests mit curl und verschiedenen SSL-Versionen machen?

https://ec.haxx.se/usingcurl/usingcurl-tls (Parameter unter “SSL and TLS versions”)

Danke, euch. Offenbar hatte ich ein Problem mit den Zertifikaten. Nun klappt es. Der Server scheint ohne Zertifikate auch zu starten. Dann kommt es zu komischen Problemen.

DANKE Euch allen

2 Likes