[radioDB] Neuinstallation unter PostgreSQL 8.2 - Probleme

Hallo Leute,

hab soeben PostgreSQL 8.2 installiert und versuche jetzt, die radioDB wieder einzurichten. Es scheint aber Probleme mit der libpq81.dll zu geben. Teste ich die Datenbankverbindung in der Konfig heißt es: None of the dynamic libraries can be found: libpq81.dll, libpq.dll. Dabei liegt die libpq81.dll ordnungsgemäß im mairlist-Verzeichnis.
Kann es sein, dass libpq81.dll nicht mit Postgre 8.2 kompatibel ist? Gibt’s irgendwelche Lösungsansätze?
Vielen Dank im Voraus!

Prinzipiell sollten alle älteren DLL-Versionen auch mit den neuen Server-Versionen zusammenarbeiten.

Ab DLL-Version 8 benötigt die libpq.dll allerdings etliche weitere DLLs, damit sie geladen werden kann. Daher bietet es sich an, auch mit der Server-Version 8 weiterhin die DLL-Version 7 zu verwenden. Also einfach “postgresql-7” als Protokoll (versteht auch der 8er Server) und die vorhandene libpq.dll Version 7 nehmen.

Spitzenklasse, vielen Dank für die schnelle Hilfe! :-))