PostgreSQL set up assistance please


I could with a liitle assistance setting up the PostgreSQL 8.4 database.

I’ve installed it in a PC (ProductionPC) running Windows Vista Business following the instructions in the mAirList Wiki.

mAirList 3 is running in another PC (Playout), also running Windows Vista Business.

There are two immediate issues:

  1. When I ‘Perform Initial Setup’ from within the mAirList Configuration Utility I get an error message that states:

SQL Error: FATAL: no pg_hba.conf entry for host “fe80::a488:dad:69a4:606d%10”, user “mairlist”, database “mairlist”, SSL off

But I have added the following line to C:\Program Files\PostgreSQL\8.4\datapg_hba.conf


host all all md5

Also I tried:


host all all md5

  1. When I try to ‘restart the server’ (start>all programs>PostgreSQL8.4>Restart Server) I get a DOS window thats states:

System error 5 has occurred. Access is denied. I get exactly the same message if I try to stop or start the server.

Any ideas?



The first error could be caused by the fact that PostgreSQL has not been restarted yet after you edited pg_hba.conf.

Regarding the “access is denied” error, are you logged in with Administrator rights? You could try to right-click the Start Menu entry and click “Run as Administrator” if so.

Hi Torben,

You correctly identified the solution to my second issue. Running the command as Administrator (even though I am logged in as an Administrator) does the trick and I can stop and start the server.

The first issue, mAirList being unable to find the pg_hba.conf file is still baffling me. I’ve rebooted the PC several times and swtiched off the Windows Firewall.

Any further ideas?



Andrew: you have ensured that mAirList can use the PostgreSQL client libraries, either by adding their path/directory to the PATH environment variable; or by downloading the client DLLs and putting them in your mAirList program folder, yes?


Hi Cad,

I downloaded the libraries from the mAirList website, unzipped the files and put them in the root of the mAirList folder on my Playout PC.

According to a support document on the website:

Allow a user from host to connect to database

“template1” if the user’s password is correctly supplied.


host template1 all md5

Allow users from 192.168.x.x hosts to connect to any database, if

they pass the ident check. If, for example, ident says the user is

“bryanh” and he requests to connect as PostgreSQL user “guest1”, the

connection is allowed if there is an entry in pg_ident.conf for map

“omicron” that says “bryanh” is allowed to connect as “guest1”.


host all all ident omicron

So I’m going to try:
host all all md5

If that doesn’t work, then I will strongly suspect that its another ‘Vista’ issue, horrible operating system.



Well, i’m afraid that didn’t work either. On starting mAirlist I get:

17/08/2009 08:03:01 Error Error connecting mAirListDB (network mode): SQL Error: FATAL: no pg_hba.conf entry for host “fe80::a488:dad:69a4:606d%10”, user “mairlist”, database “mairlist”, SSL off

I believe the problem is the IP addresses.

The error messages mentions “fe80::a488:dad:69a4:606d/10” as the source address. First of all, this is in IPv6 format - do you run an IPv6 network? If not, best thing would be to disable all IPv6 related things in Windows Control Panel if possible.

Second, this is a so called “link-local” address, the type of address used when DHCP is not available.

I strongly believe there’s some problem with your network configuration here.

Thank you Torben.

I’ve disabled IPv6 and that seems to have worked. However I now have a new error message:

17/08/2009 08:20:38 Error Error connecting mAirListDB (network mode): SQL Error: ERROR: relation “config” does not exist
LINE 1: SELECT value FROM config WHERE name=‘schemaversion’


Went back into configuration, deleted the database and started again. Ran initial set up and it worked.

Vista’s network default of IPv6 was the problem.

Thank you Torben and Cad.

I’ve imported the music successfully.

My mmd files are held in a separate folder. How do I import them?

They should have been imported automatically during the file import. Of course only if you set up the MMD folder in the config so mAirList will find them. There is no way to import the MMD information later.

Generally, the database uses the same import mechanisms as the mAirList playlist does. It also uses the exact same file import settings. If the information from the MMD files shows up properly when you drag the files into mAirList, it will also be considered during DB import.

So, if I check that the address of the mmd folder is set in config and then I delete all the records and the storage in the database, could I then start again and this time the mmd import would happen along with the music file data?

Yes, exactly.

Just try to load some of the files into the mAirList main playlist first to confirm the correct setup. It might save you some time.

I will, thanks.