PFL player not working

Hi, Just discovered that the PFL player doesn’t seem to work.

It brings it up and shows its playing but there is just no audio. i have tried changing it to another soundcard etc and still its the same.

Is anybody else having the same problem?

I do know about a bug where the PFL player ignores the device set in the config but plays on the default device instead. This has been fixed in the current snapshot:



Well, mAirList-like :wink:

Can i just check if im doing something wrong!

If i load a track in the mairlistTag, i set the ramp etc and hit File-tag (which is what i want to save to) but then i get the error message “error saving file tag… Because the file is being used by another process”

However it isn’t! The only process using it is the File-tagger and it has to use it to tag it!

i have checked re-opening the file and it has no ramp or any points set, as you would expect after seeing this message.

Any ideas?

This is a confirmed bug in v3.0.

Ok, glad you’re aware of it.

Any ideas of when i will be able to get a snapshot or a release with it fixed, as i can’t tag any files at the moment!

Before anybody says it, no i don’t want to tag to mmd. :wink:


I haven’t looked into it yet. No idea if it’s just a trivial issue or a serious problem.

Great, well i’ll keep my eyes on the forum then! :slight_smile:

New snapshot (b529) available now.

Just a quicky,

when using the file tagger/pfl i double click the file and it will usually pop up and start playing straight away to allow me to tag it.

However, when double clicking it loads it up like it would when you load the properties - so it shows artist, title, comments etc. this means you then have to click via the PFL button etc which is quite annoying when doing a big batch of tracks.

Any ideas on why this would happen?

Also in terms of PFL for the players, i save to filetag, is it likely any time that i can save to filetag when that file is loaded in the player. currently it wont let you because the file is “in use”. Also, within that PFL window, how do i get the FILETAG button to appear in the window?


You mean from with in mAirList (not mAirListTag)? That’s true, double-clicking an item open the Properties dialog without starting playback in its PFL pane. This is because other people might only want to edit the artist, title etc. but not listen to the song or set cue points.

To open the Properties dialog in with PFL active, there are several options:

  • right-click the item and click “PFL”
  • press Ctrl+P
  • click the playlist icon in the leftmost colum (this feature may have to be enabled in the config, I’m not sure if it is by default)
Also in terms of PFL for the players, i save to filetag, is it likely any time that i can save to filetag when that file is loaded in the player. currently it wont let you because the file is "in use". Also, within that PFL window, how do i get the FILETAG button to appear in the window?

The buttons can be enabled or disabled in the player GUI options configuration.

There’s not too much I can do about the “file is in use” problem. BASS.DLL locks the files for writing while they are open. One thing to try is to enable file management in mAirListConfig and enable the “load files into RAM” option. Set the size limit to a value slightly above the size of your average files so all of them will fit into the RAM buffer.

Hi Torben,

Sorry, i didnt make that very clear.

I was talking about the FILE TAGGER (mairlist tagger)

I know that in mairlist, in the playlist if you double click a file it loads in such a way as you describe, but it was in the FILE TAGGER that i had the problem… In the list of tracks down the left, usually you would double click a file and then it would open and start playing in the PFL window. However, on this particular machine it loads as if it has loaded properties.

Sorry for being un-clear, hope that makes more sense!


Never mind.

You mean, there’s one particular computer on which the file tagger reacts in a different way? Not starting the PFL automatically?

Yeah, exactly that.

I’ve never seen it do that before. It’s the first time i’ve used file tagger with that machine as well so i wouldnt have changed anything in the config to make it work in a different way as there was no point if not using it!

Is there an option somewhere where this is possible or is it some sort of bug?

i’d never seen it happen before and couldn’t see any appropriate category within the config to change it.


I have just double checked it, there is no option for that, the code is fixed.

And you’re sure that it’s the exact same version and build?

i am sure it is the latest issue/build as i downloaded the latest snapshot this morning on that machine. i cant tell you though whether the problem was there before i downloaded the snapshot though, as i’d never tried it before!


Can you try to transfer the configuration as well? Perhaps there’s some setting which I forgot about.

Oh, and does the player appear at all (even stopped) or do you just get the “click here to start PFL” button?

Do you mean you want me to send you the config?

Well, you click on the PFL tab at the top, that then brings up the bar to CLICK HERE TO START PFL, that then brings up the normal PFL window and then, from memory now, you have to start the track playing (although cant be certain as to whether it starts automatically or not).

No, I mean transferring the config from the working PC to the “broken” one. Just to make sure that it’s really really really not config-related. I’m not aware of any option which might have an impact on this, but just to be sure.