OnTheFly Error

I still cannot get my main song folder to load as an OnTheFly Database. I used to get mAirList to load but the GUI would be all over the place - missing playlists, funny toolbar buttons etc. Now I get an error message which really confuses me.

If I comment-out the Database INI, it loads fine. I have just over 12000 songs in the folder and there is no OnTheFlyCache file (despite me opting to have one). The splash screen says it’s reading the database and it takes a long while for the splash screen to vanish and for the error message to appear.


This is really strange. Obviously, the error appears when the engine tries to initialize the audio device of the first player:

  BASS_ERROR_DRIVER       = 3;    // can't find a free sound driver

However, the databases should be up and running at that time. But there’s no cache file - an evidence that the scanning might have crashed.

Do you have auto cue enabled? Perhaps there’s some sort of memory leak, using up all of BASS’ resources while the directory is scanned.

Perhaps there’s a broken file which causes the error? Can you please try to add some of your files first and try to identify which one will break it?

I have CueIn and FadeOut enabled - but all my songs (bar a few) have been bulk processed via my script (icon, end type etc) so the Cues are in the MMD files. I think the last time I tried to load all Music contents from the Browser into the Playlist window, it locked-up.

I’ll try splitting the folder and see if 5000 songs work :slight_smile: If I recall, on earlier versions it used to stop at “Y” - so I’ll roll-back the EXE and see if I get different results, too.

This issue is still evident in the current snapshot - I can add a folder of 600 song no trouble, but my main song folder of just over 12,000 MP3 tracks will not cache on startup. I still get the “Error starting engine” message box. Essentially I’m looking for the most efficient (ie: fast!) way of being able to search for items without a big folder list.

Today when I tried it, I didn’t get an OnTheFlyCache.mlp file in the target folder :s and I really don’t want to be moving several thousand files around as I’m convinced that Torben’s code is at fault :wink:

I’m still pretty sure that there’s a broken file file somwhere.

Didn’t you mention that you some files failed to import into mAirListDB as well?