ON the fly over network


I have just created an on the fly database on an office computer. my music is on an external hard-drive.
i now want to get that database to work on the studio computer, over a network.

My assumption was that if it created it using cached files on the office computer then i would then simply need to go on the studio computer, select the same directories (just over the network), tick the cached file box and then it would work fine and it wouldnt mean id have to wait hours to re-create the database!

On the studio computer, the database displays correctly and all looks like it should, the database searches as it should etc, but as soon as i put any audio via the database into a playlist i get an error along the lines of

BUILDSOURCE: CANNOT OPEN FILE “I:\60’S…” The system cannot find the path specified

that sounds to me like it can’t find the file, but all is correct in terms of locations etc as i have double checked them.

if i go back into the config and use the test option on each database it says that it is all ok also.

Im rather confused!


Are the drive letters the same on either computer? Because the OTF database stores absolute file names in the cache file.

You can change the drive letter in Windows’ Computer Management.

Hi torben,

Yes, i have just double checked and they are both the same.

What i did just think was that on the office computer, as the hard drive was plugged into it i set the database to go straight to it, rather than going via network places and selecting the hard drive…

When opening up the database on the studio computer, i was obviously using network places. So i wondered if as it was networking if that made any difference to file names, as it is saying it can’t find the file.

However, i did a quick small database test and still i have no luck with it as i still get exactly the same error!

Seem to have got it sorted now.

The problem was that when setting the location on the office computer to go via the network, the directory it was setting still cut out the whole network line and went straight to the hard-drive.

The studio computer database obviously had the network line, so i had to manually insert the network line to the other database and then it all seemed to spring to life.