Network Database Connected but wont play audio

I’m using postgresql to run the Mairlist across a network. Mairlist logs in to SQL and connects, the sync of the database was successful, but it wont play any audio. The storage is pointing to the drive where the audio files are but I get the error of cant not find specified path, when I look at audio file tab from database, it shows where the file is ?.

Perhaps missing sometimes really obvious been at this since 6am

First of all, can you please enter the serial number of your license into your forum profile.

Also, which mAirList version are you using?

[quote=“Torben, post:2, topic:8299”]First of all, can you please enter the serial number of your license into your forum profile.

Also, which mAirList version are you using?[/quote]

Hi Torben

Its 3.0.15 Build 685

Thank you.

Are the files stored on a network drive, or on the local drive of the first mAirList computer? When you look at the filename displayed in the Properties dialog of the second computer, does that path actually exist on the second computer, or is it a path that is only accessible on the first computer?

Remember that the SQL server only stores (and serves) the names of the files, but not the actual files. They must be accessible through a network share from the second computer.

You can adjust the path under which mAirList looks for files from a particular storage with the “local folder” setting in the storage configuration dialog. (In mAirList 4.x this would be the “Storage Redirection” tab in the DB connection config.)

The postsql server and audio files all sit on a windows 2003 server. The playout machines, which are XP PRO Mairlist does successfully connect to the SQL server, It synchronized the database, you can the see the list of audio in the database manager, just not physical play it I’ve got the Audio store set to M:\Database\Itunes.

You click on a file to play it and see "Error playing item. Cant not open file M:\database\music\134itunes .file name the system cant not find specified path. What is the 134 bit, there isn’t a folder of that name ?

Playout machines are quite happy to map to the M drive, its does via a logon script

I’ve tried the storage redirect in quite a few paths M:\ or M:\database or M:\database\music\itunes.

None work

Ah, it’s the \134 thing. All backslash characters are replaced by \134.

That’s an issue when using PostgreSQL 9.1 or newer which uses a different way of transmitting backslash characters.

mAirList 3.0 was written for PostgreSQL 8.x which still uses the old format.

I believe mAirList 3.1 (the last version you can use on your v3 license) already includes a fix for that so that it works with PostgreSQL 9. So try upgrading to v3.1.9.

If you can’t upgrade for some reason, you can try to switch the PostgreSQL server back to the old format using the standard_conforming_strings option. It must be switched to “off” in the global configuration (that’s exactly what recent mAirList versions do, only for the session but not globally). See here:

It works Yay, tried upgrading Mairlist first, that didn’t help. I had to roll postgresql back to version 8.4, but its working.

Thanks for your help

I have looked in the meantime, and the fix is not in v3.1.9 but only in the latest v3.1 snapshot that you have to install on top of it.