mAirlList buffers when it changes track

Hi there.
Certain tracks in mAirList make the software freeze when changing tune, making it unable for me to use the software when it’s switching to a new track. I’m wondering if there’s anyway to fix this? I don’t think it’s related to the song size as some songs as small as 5MB cause issues. My computer shouldn’t be to blame as it has an Intel i9-10900X processor.

Here is an example of the problem, I am switching from a jingle to a song.
Note: the tracks themselves do not stutter at all when switching, it sounds fine. However I cannot use the software to activate my microphone for example while it changes track.

Thanks for reading, any help would be very much appreciated! :slight_smile:

For how long does it freeze?
Since when does it appear?
What mAirList version (v6.?.??) do you use?

1 Like

It normally freezes for at least 2 seconds, sometimes around 4/5 seconds. It’s been appearing since I started using the software a few months ago and I have Home Studio version 6.2.8.
Edit - I’ve just seen 6.3.2 is out. I’ll update to that version to see if it has the same problem.


Do you use the program on a HDD or on a SSD?

I had similar problems when I installed the program on my old HDD. After I installed it on the SSD, everything worked fine :wink:

Kind regards
Oliver :slight_smile:

1 Like

My music and mAirList itself is on an SSD, but thank you for the reply.

-Lucas :slight_smile:

1 Like

hmm okay… :confused:
Do you use any background scripts, which might reload after each start of a song?

1 Like

No, I don’t have any enabled :frowning:

1 Like

Any security/antivirus software? (Just a guess.)

1 Like

Oh, and it would also be good to learn more about your audio configuration. WASAPI, DirectSound, ASIO? Does it also happen when you set all outputs to the “No audio output” device?

1 Like

Thank you for your reply. I have Norton Antivirus. I only do radio as a hobby, so I have a Rode NT-USB connected to my computer via USB and it uses WASAPI. It also plays back into my headset using WASAPI too. The issue still happens when I set all outputs to "No audio output”.

Can you disable Norton temporarily?

1 Like

I’ve just disabled it and unfortunately it makes no difference.

Ok, going on… Can you also turn off album art in the playlist GUI settings?


Ah turning off the album art fixed it, thank you so much!

Whilst you’re here, I have one last ongoing issue…
The longer the software is open, the higher the delay is between me speaking and the software picking it up and broadcasting it. Refreshing my input device temporarily fixes it but I have to do it several times an hour in order to not get put off by it.
If you wouldn’t mind helping me fix that then I’d be extremely grateful, thanks again!

What have you set as the sample rate and format for the record device in Windows sound settings? Is it 44100 or 48000?

1 Like

Oh, and about the album art - it is cached in a file called AlbumArt.db in the mAirList data folder (see config -> Advanced -> Data Folders). Can you check its size? And there are no networks drives involved here, I suppose?

1 Like

My microphone is set to 2 channel, 16 bit, 44100 Hz. And the size of the AlbumArt.db file is 9.78MB.