Insert doesn't work (anymore)

Strange … I had this with the 2.1.28 version and now also with 2.1.29, and first it worked fine, later I had to push the Insert button a few times before something showed up, now nothing happens anymore.

So, in mAirList, I click Insert -> Playlist… or Insert File… nothing happens.
Earlier today it worked.

I’m working on my layout and skin.ini files, but I can’t imagine that could cause this problem.


Suddenly found it! I’ll post this message anyway…

First I have to click inside the playlist area and then click Insert :slight_smile:

Yes, that’s true. You need to focus the desired playlist first. This is for the people who run more than one playlist. I can make mAirList default to the first playlist in case none is selected.

As someone who runs two Playlists, my vote is not to make mAirList default to the first Playlist.

This would force the presenter/producer to move the focus to the desired Playlist before doing the Insert. IMHO, this is preferable to them Inserting items into the ‘wrong’ Playlist!


Ok, then how about defaulting to the first playlist if there is only one?

I have this problem.

I also have created my own layout using skin/layout.ini.

The solution to the problem as said is just focus on a playlist, basically click the playlist first, then do the inserting.

Ok, then how about defaulting to the first playlist if there [b]is[/b] only one?
Sounds good. :)

Even better would be—when there is more than one Playlist—to present a listbox to allow the user to choose which Playlist they want to Insert the item(s) into. Though that may be ‘overkill!’ :wink:


… or disable the button as long as no playlist has focus.

A good and sneaky idea, Torben: and obviously much less work to program it that way! :wink: