FLAC & Auto Importer


Does anyone know if Auto Importer can import FLAC or have successfully got it working?

I can import FLAC within DB, however not from Auto Importer - maybe a config setting change I’m missing…

Thanks in advance,

I’m working with FLAC files and mAirlist DB, but haven’t tried Auto Importer to date.
Must try it on a test system. :thinking:

Could you find any helpful entries in the mAirlistDB Auto Importer Log?


You must enter “flac” (without the quotes, and without a period) under config -> GUI -> Browser to the list of known audio file types. This list will also be used by the Auto Importer.

Thank you UiNobbe and Torben, the missing part was the file type that was what was needed in the config.

Useful hint out of another thread:

October 2018: Auto Importer

Thanks UiNobbe…

Just struggling getting FLAC tags to carry over into the DB now, ID3 works fine for mp3s.

My experience is: Each tag field which is not defined as a standard attribute …

Configuration > Miscellaneous > Standard Attributes

… will be imported as “Other Attributes”, please see attached from the properties dialog:

Thanks, FLAC import with tags is fine from import within the main DB application - everything imports great - it just seems to be Auto Importer which isn’t grabbing that tag data from the file before it writes to the Database.

@AJ1: Actually the same metadata import code is used for both the Auto Importer and the other import functions (DB sync, DB manual import, drag&drop into playlist etc.), so if it works in the manual import it should also work in the Auto Importer. Can you verify that the respective import options are set correctly in the Auto Importer folder configuration?

@UliNobbe: Standard Attributes vs. Other Attributes is just a matter of presentation. Standard Attributes have a nice input field on the left, all other attributes go into the list on the right. But inside, they are all in the same key/value list (you can verify that by copying an item to clipboard with Ctrl+C and looking at the XML output in a text editor). So in other words, defining Standard Attributes is nothing but designing the appearance of the Attributes tab. It does not affect import at all.

Argh - I thought it would have influence on the mAirlistDB configuration tab “Standard Attributes” and the list there must be the same as in the mAirList configuration?

Confused :confused: but [OT]: Uli

The lists in the global configuration and those from the connected databases (remember you can have more than one!) are merged.

For the columns in the DB app, only the attributes from the DB settings are used.

In a typical mAirList setup with only one database, you would usually only define the attributes in the DB settings. No need to define them twice.

Hi Torben, 100% the same, MP3’s ID3 tags are fine from Auto Importer into DB - but when it’s a FLAC, metadata is only read if I import directly in DB application, but not Auto Importer - very strange.

To replicate:

Import FLAC in your DB Application - Metadata should populate the DB.

Use Auto Importer to import FLAC into Database - File will import but no metadata from the tag.

I’ve tried with this standard Sony file too…


Same issue, (this just has an album reference in the tag)

** Could it be permissions issue with Auto Importer? ** however I have tried running as administrator and that doesn’t seem to like it.

Turned out that the DB Importer did not load any BASS plugins. That was also the reason why you had to enter the file extension manually (which is actually not necessary if the plugin gets loaded properly).

Without the BASSFLAC plugin, file can be opened/played, but no metadata is available.

Should now be fixed in build 3952.

You’re a star - thank you Torben - great support.

1 Like

Hi Torben,

Any chance this fix could be added to the 6.2 Beta, thanks in advance.

Assume that all changes in v6.1 will automatically be merged into 6.2 for the next snapshot. (Note that there will not be an entry in the changelog for changed merged from older version, as the automatic Git merge cannot do it for me.)

Thank you :white_check_mark: