File on FTP server with white space in file name

Hi all,

Our news is provided by FTP. Unfortunately there’s a white space in the file name (like ‘our news.mp3’).

The news provider is unable to change this. Is there a way to add this dynamic item to the database? I’ve succesfully added FTP items without spaces (like ‘ournews.mp3’) but can’t seem to add this one.


Have you tried using %20 in the URL? This is the standard way to encode spaces in URLs.

Hi Torben,

I have. I also tried surrounding the URL by single and double quotes.

Headlines 2

The file name is ‘headlines 2.mp3’. mAirlist seems to add an additional slash before %20.

I’ve also tried escaping it with headlines%202.mp3 and headlines/%20.mp3.

Just to be sure - are we talking about the “File on HTTP/FTP server” playlist item here? Added manually to the DB library?

Yes, that’s correct.

Would you mind sending me the URL (via e-mail to so I can carry out a few tests?

Not at all. I’ve sent the URL to you by mail.

Thanks. For me it works. Pasted the URL (the one with the space!) exactly as you sent it to me:

Hi Torben,

Thanks for testing this. I’m not sure what happened… I must have made a mistake with the original URL in my first tests I guess.

I’ve recreated the item with the URL I’ve sent to you and it works here as well now…

Sorry for the inconvenience!



1 Like