Browser toolbar buttons 'disappearance'

I’ve just added my v3.0 config files to a v3.1 (b757) mAirList, and the Browser no longer shows any toolbar (!).

How do I switch this back on, please?

Thanks in advance.


I’m not aware of any changes regarding the browser toolbar between those two releases. Have you checked the relevant skin.ini settings?

The skin.ini files are identical (I copied my 3.0 settings into my new 3.1 install).

Perhaps I should make it clear that the Browser toolbar is still present, but it doesn’t have any buttons on it.

So to be more accurate, I should have said I have a blank Browser toolbar in v3.1. :smiley:

UPDATE: In Layout Designer, everything displays correctly, including the Browser toolbar buttons. In the main mAirList program, the Browser toolbar is ‘empty.’ If the Browser toolbar button objects ARE there and are just hidden or somethng, they are not clickable; but it seems that the buttons are just not there.


OK, I’ve worked out what the cause of this ‘problem’ was. ;D

It’s this line in skin.ini, which I think is a ‘legacy’ from V2.x:

With this line, you get an ‘empty’ Browser toolbar. Remove it, and everything is normal. So, this is actually a useful setting/feature, although if you don’t want Browser toolbar buttons, it doesn’t make sense to show a toolbar in the Browser at all, right? Just ‘remove’ the toolbar and thus extend the Browser to fill the entire space allowed for it.

Hence: please DO NOT ‘fix’ this! Instead, I suggest:

  1. Rename the setting (INI key name) from List to ShowToolbar.
  2. ‘Swap’ the setting’s functionality so that on is the default, and off ‘removes’ the Toolbar and ‘expands’ the Browser proper to fill the Browser area as defined in layout.ini.

What does everyone else think?

Yes, I know there are no features being added for a month or two. :smiley:


The “List” option is supposed to switch the toolbar into “list mode”, with small icons and captions displayed side by side (as opposed to the default setting where the caption is displayed below a larger icon). I don’t know why it is hiding the toolbar completely, nor why it is only happening in v3.1. Perhaps you can send me your skin and layout files for testing?

I can easily introduce an additional option for hiding the toolbar. That’s so simple that it doesn’t count as a new feature, not even this summer :wink:

I’ll do that when I get home from work tonight. :slight_smile:


Torben, here’s my entire set of INI files for 3.0.

Like you, I’m baffled about why List=on produces a ‘blank’ (empty) Browser toolbar in v3.1.

CAD (7.31 KB)

This is still mysterious to me, but I somehow made List=on do what it’s supposed to. Please try Build 758.

There’s now also a “Visible=off” setting (for both the browser toolbar and the main toolbar) to hide the toolbar altogether.

The browser toolbar options are now expected in a section named “BrowserToolbar”, putting them into the “Browser” section for compatibility does still work though. I just thought “BrowserToolbar” is much more straightforward, in particular with the new “Visible=off” setting which may confuse people when in the “Browser” section.

Good news: List=on now works correctly! ;D

Bad news: Opening config causes a RangeCheck error (bugreport attached). If I click continue application, the Playlist has no Players in it and trying to change the number of Playlists causes a BoundsError. :frowning:


bugreport.txt (22 KB)