Audio config issues

Hi everyone,

I need your expertise…

Yesterday, I had almost the perfect configuration. MAirlist was working like a charm with my D&R Airence console. I had just one problem though, my Pc was too old and not fast enough. I had glitches sometimes during transitions.
We were suppose to launch our new radio station today. So, this morning, I decided to buy a new PC (Intel Core i5-4460 - 8Go RAM - 1To HDD Windows 8.1).
I installed the exact same configuration but I could not get to have Deck A, B et the cartwall to play on 3 different faders. I can have A and B, A and Cartwall or B and the cartwall. I try every configuration (I spend the day on it) different USB port, reinstalling mAirlist and I get the same result.

I check the Airence faders playing a stream and switching default outputs in Windows and it works but when I play songs from mAirlist I can’t get it to work on 3 diffrent WASAPI outputs…

When I set the outputs in the mAirlist control panel the two firsts outputs work but I get the mention Error by the name of the file I drag in the third player.

Have one of you ever experienced something like that ?

Thx for your help !

Hi Steve,
did you copy the configuration from your old PC to the new PC?
I yes you should at least re-do the Audio configuration, because of the new Hardware, mAirList can not find the same Audio Devices. They have either unique numbers or the are numbered 1 to xx, depending if you are using Direct Sound or WASAPI. Never the less, both assignments can not match under your new OS.

Same Thing can happen if you just Change the USB port for your Audio Device.

Best Regards

Hi shorty.xs, hi everyone,

Thx for your help. It was in fact a Windows 8 and 10 problem handling USB port under xHCI by default. I had to switch to EHCI instead.

Love my mAirlist - Airence configuration ! (again) :-*

Take care guys !

Hi LeMixx,

I have the same problem with mixer Airlite & Windows 10!
if I use only 2 stereo channel everything works fine but if I try to set the third and fourth channel
These do not work and windows 10 gives me error USB controller insufficient resources.

explain to me , please, how did you turn off xHCI ?
setting the bios or from windows?
help me!
Thank you

[quote=“barty, post:4, topic:10119”]explain to me , please, how did you turn off xHCI ?
setting the bios or from windows?[/quote]

Sorry, can’t answer this question. Just wanted to confirm that xHCI is an issue with the Airlite and Airence, and you should definitely turn it off. I know of at least two users who had similar problems, and solved them by turning of xHCI.


I have the same issue but with win 8.1 on a brand new intel7 pc. Anybody that knows how this is turned off?

Some of the most recent Intel chipsets don’t allow you to turn it off anymore.

I think this is only possible on Intel Chipsets, Ivy Bridge or later. If it is possible, you should find the setting in the BIOS/UEFI Sttings.
But this is only there if the Board uses USB3 Host built into the Chipset. There are Mainboards where the developers think it is better to implement a 3rd party USB3 Host Chip. These usually are implemented really bad into the BIOS/ UEFI.

I’m not sure about AMD platforms, here is an example of an AMI BIOS of an older Ivy Bridge Platform, that can turn off USB3 function.
Just to get an idea how this could look like, this is take from a user guide with some advanced description.


What about a USB2.0 USB Hub. Usually if there are compatiblity issues USB3 to USB 1.1, a Native USB 2.0 Hub can solve these.
It seems the Audio Device in the D&R desks are USB 1.1 and as USB 3.0 is only backward compatible to USB 2.0, USB 1.1 device can not work directly.

Would it make a difference if the mixer is plugged into a usb 2 port in stead of an USB 3 Port? Or adding an additional USB2 Card?


If you have a native USB2.0 Port on your Computer, it is worth to try it.

Yes, The Airence doesn`t really like being plugged into a USB 3 port