Preventing commands when PFL/PROPERTIES OPEN

Another request.

I use a custom keyboard so random letters are therefore used to make mairlist do what i wish.

I do therefore have a problem. if i open up the properties tab on a file in mairlist and start typing on a normal keyboard i end up having things like carts starting to play when i dont want them to.

Basically, is there a way that you could have an option so that when you have the properties/pfl box open it prevents any commands in mairlist with regards to audio playout.

Basically so that i can adjust file names etc etc.

Hope this is understandable.


This would be very hard to implement.

Is that keyboard programmable? Can’t you just assign any special combinations (Ctrl+Alt+something) to the keys?

I will have a play and see what i can do then.

Would it not be like the browser where you simply copy windows again?

Just tried the keyboard.

When i hold down Ctrl and then press a key, once cancels out the other.

e.g. Holding Ctrl, press button which for example is Num6 and it flickers between the two, rather than letting me set it as that.

It did however work properly when a letter key was pressed. seems it doesnt like NUM keys. Any ideas???

If i was to get it to work with Ctrl + X, wouldnt that mean everytime i have to play an item i would have to press Ctrl and the key??

Sorry if im being a dunce

With an ordinary keyboard, it works just fine here: Enter the “Key” field in the config, hold Ctrl (“Ctrl” will appear in the field) and press NUM 5, then you have “Ctrl + 5 (NUM)”.

The hotkeys are handled at a central location inside the application. It’s not possible from there to tell whether there is a dialog window active.

Lackster: check that you don’t have one of those ‘key manager’ programs running. Many PCs nowadays have keyboards with ‘extra buttons’ (like e-mail, Internet, Media, etc.) and these are invariably controlled by an app. loaded at Windows start-up: if you’re running one, it may be ‘interfering’ with mAirList key detection.



I do have one of those keyboards, USB connection, that has control buttons at the top.

If it is running one of these, is it simply a case of deleting it from running at startup??

Cheers for that

If it is running one of these, is it simply a case of deleting it from running at startup??
That would be one option, yes. Most of these utilities have an icon in the System Tray with a right-click menu option for [i]Run at startup[/i] or similar, which you can simply un-check; sometimes you need to rootle around in Control Panel to find the 'extra keys' utility and un-check its startup option from there.

If you never ever use the ‘extra’ keys, you might instead prefer to uninstall the utility completely. In my experience, all of these keyboards work perfectly well without the utility (though obviously the extra keys then ‘do nothing!’). Even if you do decide to do that, you should FIRST try just stopping the utility from running at Windows startup, to see whether or not that cures your F12 detection problem.

As always, glad to help!


BRILL. Will have a play later on today.

Once again. THANK YOU