mAirList 5 Build 2566 - Browser Problem - Darstellungsfehler

Hallo,

ich habe das Problem in mAirList mit dem Browser. Die Hintergrundfarbe ist bei uns schwarz und die Schriftfarbe in Gelb.
Das funktioniert auch gut, aber wenn man über den Button “Hinzufügen” einen Ordner hinzufügt, dann ist lediglich die Liedlänge in der richtigen Farbe,
der Titel hingegen ist in schwarzer Schriftfarbe. Wenn man einen Titel anklickt, dann wird die Farbe sichbar, aber nur für den angeklickten Titel.

Gibt es dort in der skin.ini was besonderes einzustellen, was ich vergessen habe ? Ich bekomme es einfach nicht hin, da alle anderen Ordner (Datenbank, Papierkorb…) doch richtig sind.

Zum besseren Verständnis habe ich eine Grafik beigefügt in dem man sehen kann: Links der zugefügte Ordner mit der falschen Schriftfarbe (schwarz) und Rechts das Datenbankfenster wo es richtig ist (in Gelb).
Zusätzlich noch ein Auszug aus der skin.ini.

Für einen Lösungsvorschlag wäre ich Euch dankbar.

Liebe Grüße
GertiWL


mAirList Browser.jpg

mAirList skin_ini.jpg

Der Verzeichnis-Browser basiert auf einer fertigen Komponente (Virtual Shell Tools), die wiederum auf dem Virtual Treeview ausetzt. Der Datenbank-Browser hingegen ist direkt mit dem Virtual Treeview realisiert.

Ich vermute, dass die Virtual Shell Tools ihrerseits irgendwelche Farbeinstellungen vornehmen, so dass die Werte aus der skin.ini unberücksichtigt bleiben. Ich will gerne mal versuchen, ob ich das umschiffen kann.

Würdest du bitte zu diesem Zweck einmal die relevanten Teile der skin.ini hier als Text posten, nicht als Screenshot - dann muss ich nicht alles abtippen.

Hallo Torben,

gerne sende ich Dir die relevanten Teile der skin.ini.

[Browser]
BackgroundColor=#000000
FontName=Arial
FontSize=8
FontStyle=1
FontColor=#FFFF00
SelectedRowColor=#8A2BE2
FocusedSelectionColor=#6495ED
UnfocusedSelectionColor=#5F9EA0

Danke!

Es ist wie vermutet - die Virtual Shell Tools übernehmen standardmäßig die Farben vom Windows Explorer und ignorieren eigene Farbeinstellungen.

Man kann das aber ausschalten. Ich habe im neuen Snapshot 2567 zu diesem Zweck eine Option bei den Browser-Einstellungen hinzugefügt, “Windows-Explorer-Farben ignorieren”.

Bitte teste doch einmal, ob das den gewünschten Effekt hat.

Hallo Torben,

mit dem Snapshot 2567 funktioniert es perfekt.

Vielen Dank für den schnellen Support.

Liebe Grüße

GertiWL

Freut mich, gerne.