DB Issue

Hi Torben

I have just downloaded the very latest release (network version)…

i have now got my database set up, added the files etc etc and even created the hour templates.

in mairlist, if i use the DB playlist, it brings up the playlists fine, inserts them to the playlist fine and everything as it should do.

The problem i have come across is the database search, basically it doesn’t find anything! no matter what i type it doesnt find anything, even though in the DB it show up fine all the files where it should do. I have tried it with both (all databases) and MairlistDB (network mode) and neither brings up any results!

I used the wiki page to set up the database, following as it stated and all worked as it should.

Any ideas?

Probably an SQL dialect issue. I cannot look at it right now because I’m away from home, no PostgreSQL on my laptop :wink:

Hi Torben,

Just wondered if you’ve had any chance of looking into this problem yet?


If anybody else has experienced it?


Ahhh, may have just found the problem!

It seems that the database search is case sensitive for me at the moment!!

if i am searching (Telstar) i would have the following problems…

telstar - nothing
TELSTAR - nothing
Telstar - works as that is as it displays in the playlist…

is this a setting that can be modified or is this a bug?


if the search is really case sensitive, than i guess only with the network version or happend in a new version.
I do the same with the MAL-DB Local version and there it is not case sensitive.



Im using the network db version when im having the problem. i guess its just an option in the postgreSQL bits, but i have no idea what to do!

I believe the semantics of the LIKE operator is different from SQLite. I need to use ILIKE on PostgreSQL.

By the way, this should be fixed now in the latest snapshots. And v3.0.6 will be released today.