b601: Cartwall Players always default to Elapsed Time

I’ve chosen remaining time as my default in config. for Cartwall Players, but they stubbornly come up as (for example) +0:00.0.


Can you please check what the “DisplayMode” setting in the “Cartwall” section of GUI.ini is set to?

Btw, we’re at v3.0.8.610 now.

Will update myself later tonight, and will also check the GUI setting.

[the next day (I have a REALLY bad cold this weekend!]

I can confirm that the Config app. is writing Remain into GUI.INI when you choose ‘elapsed time’ in Config, and is writing Elapsed into GUI.INI when you choose ‘remaining time’ in Config.

Changing the entry manually solves the problem. Curiously, Config seems to be READING the GUI.INI file correctly. After the manual change to Remain, if you then open Config again, it shows ‘remaining time’ correctly!

So, it looks to be a simple problem limited to when Config WRITES the time options back to GUI.INI (i.e. when Config is Saved).


The problem was that the captions in the list were in a wrong order (elapsed an remain swapped). Sorted out now.