AutoImporter

wir haben ggf. einen denkfehler:

Upload erfolgt über FTP in den Ordner Upload Sendungen (NAS)
Dieser Ordner wird auch überwacht.

Soweit alles gut.
Neue Tracks werden erkannt,
convertiert (soweit das eingestellt ist)
_dann folgt z.B.
uploading: storage 32, filename The Les Humphries Singers - Car.mp3, folder 319, policy Rename
und dann aber
error: Invalid storage (HTTP/1.1 500 Internal Server Error)


01.PNG

Greift der direkt auf die Datenbank zu (PostgreSQL) oder ist da noch ein DBServer zwischengeschaltet?

Sicher, dass der Speicherort 32 noch existiert? Nicht zwischenzeitlich gelöscht wurde?

es läuft atm der 5er InternetDBserver, (in der 5er Konfig sind aber beide DB angemeldet) (allerdings bekomm ich ne Fehlermeldung beim Start. siehe unten)

mich verwundert nun grad auch das da steht mairlistDB autoimporter, da wir ja ne postgres DB nutzen.

OK; Wegen der Fehlermeldung hatte ich die postgresDB rausgenommen.
Import geht nun, aber was mach ich nun mit den Fehlermeldungen ?


01.PNG

Beide gleichzeitig darfst du nicht eintragen! Sonst kommt mAirList durcheinander, weil es sich ja im Grunde um dieselbe Datenbank handelt. So ist die Warnmeldung zu verstehen.

Also NUR die PostgreSQL ODER die DBClient eintragen! Die andere komplett löschen!

alles klar, erledigt. danke.

ich komm hier grad nicht weiter,
beispiel:

playliste wird vom moderator zuhause erstellt.
als mlpe exportiert, dann per ftp oder googledrive ins studio geschickt,
autoimporter erkennt das alles und handelt entsprechend.
die mlpe bekommt sogar ne ID, weshalb auch immer, allerdings finde ich diese mlpe weder im uploadordner noch im importordner.

die zu lösende aufgabe ist:

moderator erstellt eine gemischte playliste, aus seinen mp3s und dem von uns per internetDB zur verfügung gestelltem promomaterial.
anschliessender upload seiner mp3s und der mlpe.

wenn ich die playliste aus der DB mit der ID in die verwaltung importiere wird mir angezeigt, da ist ne playliste, mit mp3s die auch im mixeditor funktionieren,
sobald die in der ausspielung startet wird alles übersprungen.

edit. grad gesehen, es handelt sich (weshalb auch immer) um eine zu entpackende playliste,
entpacken über rechte maustaste han ich aber nur im ausspielfenster gefunden, wie geht das in der DBverwaltung (kalender playliste)

Für .mlpe ist das nicht gedacht, nur einzelne Dateien. Geh davon aus, dass mAirList so richtig durcheinander kommt, wenn du da eine .mlpe-Datei hochlädst, vor allem, wenn da noch Dateien dabei sind, die schon in der Datenbank existieren.

Vorschlag: Moderator lädt erst die benötigten (= fehlenden, noch nicht in der DB vorhandenen) MP3s hoch, und baut die Playlist danach direkt im Sendeplan-Editor zusammen.

Nachtrag: Es wurde schon angeregt, den Auto Importer zu erweitern, so dass er nicht nur Dateien für die Bibliothek importieren kann, sondern auch Sendepläne. Dann würde das mit den .mlpe-Dateien schon eher gehen.

Frage:
Muss beim Autoimport die Datei verschoben werden ? oder geht auch einfach einen Ordner überwachen ? (z.B. den FTP ?)

Theoretisch kannst du auch direkt den FTP-Ordner überwachen. mAirList wartet, bis sich 10 Sekunden lang die Dateigröße nicht mehr geändert hat, sprich: der Upload (ganz offenbar) abgeschlossen ist.

grad probiert, da ich keine einstellung gefunden habe um das verschieben zu deaktivieren sind beide also identisch.
kommt aber ne fehlermeldung, datei in benutzung…


01.PNG

Welche mAirList-Version/Build?

hm, da ich das hier für die automation probiere, auch auf dem rechner wo grad die 4er läuft, kann ich die 5er ja nicht starten, hab aber vor ganz 2 tagen erst den snapshot installiert.

hm, grad mal deinen vorschlag getestet.

upload der mp3 vom moderator per ftp.
autoimporter läuft:

taucht auch in der DB auf
ABER:

im cueeditor nicht spielbar:


01.PNG

01.PNG

01.PNG

Was kommt für eine Meldung, wenn du im Cue-Editor auf Play klickst?

Es erscheint die Fehlermeldung, daß der Titel nicht gefunden wird:


not-found.PNG

Wurde der Speicherort erst kürzlich angelegt? Ggf. vergessen den DBServer danach neu zu starten?

Vielleicht auch mal ins Log des DBServers schauen, ob da mehr zu der Fehlerursache steht.